On s'dit tout

Forum pour débattre des questions high-tech, demander, partager une info, des astuces et des tutoriels. Rejoignez-nous !


    RNIS

    Partagez

    Admin
    Admin

    Masculin Nombre de messages : 388
    Age : 34
    Localisation : sefrou
    Date d'inscription : 24/07/2006

    RNIS

    Message par Admin le Ven 22 Déc - 19:15

    Introduction

    Cet article a pour but de présenter la configuration d'un lien point à point entre deux routeurs sur des interfaces RNIS de deux manières différentes. Le tout avec sur chaque routeur une seule interface de BASE (BRI 0). La première configuration met en place des profils d'appels (dialer) que l'on nommera par la suite Dialer profile tandis que la deuxième met en place des mappages directement sur l'interface RNIS du routeur concerné, on dénommera cette configuration Dialer Map. Voici ci-dessous le schéma logique de configuration entre les deux routeurs :


    1. Configuration Dialer Profile sur le routeur ROUTEUR_NUM1

    On part du principe que les configurations de base ont déjà été effectuées sur les routeurs (hostname, password vty, console, interface Ethernet0, ...).
    1.1 Première étape : configuration générale

    Il faut tout d'abord prévoir un nom d'utilisateur pour le routeur distant, dans notre cas le routeur ROUTEUR_NUM2, ainsi qu'un mot de passe. La première commande ci-dessous permet de rentrer en mode de configuration global puis la suivante de spécifier un compte pour le routeur distant :
    ROUTEUR_NUM1#configure terminal

    ROUTEUR_NUM1(config)#username ROUTEUR_NUM2 password 0 mot_de_passe

    Ainsi un login et un mot de passe ont été mis en place pour que le routeur distant puisse se connecter sur le routeur ROUTEUR_NUM1. Il faut à présent préciser le type des switchs RNIS qui est utilisé lors de la commutation des paquets sur le réseau RNIS. Cette information est fournie par votre fournisseur d'accès au réseau RNIS (ou à vous de préciser dans le cas d'un réseau complètement interne). Dans notre cas, nous configurerons un type « vn3 » couramment utilisé. Voici la commande utilisée pour mettre en place ce type :

    ROUTEUR_NUM1(config)#isdn switch-type vn3

    Ensuite il faut spécifier au routeur d'utiliser tel dialer dans le cas où l'adresse IP demandée est sur le réseau distant. Pour cela, toujours en mode de configuration globale, il faut saisir la commande suivante pour le cas présent :

    ROUTEUR_NUM1(config)#ip route 172.16.27.0 255.255.255.0 Dialer1

    Avec cette commande nous lui indiquons que si il veut rejoindre le réseau 172.16.27.0 il faut qu'il s'adresse à l'interface virtuelle « Dialer1 ». Nous définirons le terme virtuel associé à l'interface Dialer1 dans la partie 1.3 ci-après.

    Enfin la dernière commande à utiliser dans le cas d'une communication non perpétuelle, ce qui est toujours le cas pour les liens RNIS, est de spécifier la négociation lors du premier appel émis ou reçu. Voici la commande à utiliser :

    ROUTEUR_NUM1(config)#isdn tei-negociation first-call

    Pour plus d'informations sur cette commande se référer à : http://www.cisco.com/warp/public/129/bri-layer1.html
    1.2 Deuxième étape : configuration de l'interface BRI0

    Durant cette étape, nous devons configurer l'interface physique RNIS, dans notre cas l'interface RNIS de BASE : BRI0. Voici les commandes associées à la configuration de cette interface avec une encapsulation PPP (Point to Point Protocol) et une authentification chap (Challenge Handshake Authentication Protocol) :

    ROUTEUR_NUM1(config)#interface bri0

    ROUTEUR_NUM1(config-if)#ip address 172.16.26.2 255.255.255.0

    ROUTEUR_NUM1(config-if)#encapsulation ppp

    ROUTEUR_NUM1(config-if)#ppp authentication chap
    1.3 Troisième étape : configuration de l'interface Dialer1

    Maintenant il reste à configurer l'interface dite virtuelle Dialer1. En effet, cette interface est virtuelle car on peut en créer autant que l'on veut sur un routeur CISCO, à partir du moment où l'on rentre au minimum une ligne de configuration associée à cette interface. Voici la suite de commande de configuration pour cette interface et sa création :

    #création de l'interface Dialer1 et on rentre dans l'espace de configuration de cette interface.

    ROUTEUR_NUM1(config)#interface Dialer1

    # cette ligne permet de ne pas spécifier d'adresse IP sur cette interface, pour plus de détail :

    # http://www.cisco.com/warp/public/701/20.html

    ROUTEUR_NUM1(config-if)#ip unnumbered Ethernet0

    # cette ligne permet d'éviter les broadcast direct, pour plus de détails :

    # http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/np1_r/1rprt2/1ripadr.htm#1025670

    ROUTEUR_NUM1(config-if)#no ip directed-broadcast

    #encapsulation ppp

    ROUTEUR_NUM1(config-if)#encapsulation ppp

    # on spécifie le nom (hostname) du routeur distant que l'on va appeler

    ROUTEUR_NUM1(config-if)#dialer remote-name ROUTEUR_NUM2

    # spécification du temps d'attente (180 secondes ici) avant l'interruption de l'appel

    ROUTEUR_NUM1(config-if)#dialer idle-timeout 180

    # on spécifie le numéro qu'il faut saisir pour joindre ce routeur (numéro en France, à Paris par

    # exemple). Attention à spécifier les chaînes de sorties si vous en avez (16 5 pour sortir du bâtiment

    # par exemple). Cette commande suivant certains cas peut aussi ce transformer en « dialer caller

    # 0188888888 ».

    ROUTEUR_NUM1(config-if)#dialer string 0188888888

    # authentification chap

    ROUTEUR_NUM1(config-if)#ppp authentication chap pap

    Ce premier type de configuration permet de créer une entité pour chaque routeur distant appelé ou appelant, en créant autant d'interface « virtuelle » que l'on veut.

    Notre premier routeur est configuré. Nous n'avons pas abordé les différents principes de sécurité avec notamment les access-list et les dialer-list. Cet aspect ne sera pas abordé dans cet article. Il nous faut maintenant configurer le second routeur pour que le lien RNIS soit opérationnel bidirectionnellement.
    2. Configuration Dialer Map sur le routeur ROUTEUR_NUM2

    Ce deuxième routeur sera configuré selon la deuxième méthode. Il est bien évident qu'il peut être configuré de la même manière que le premier. Cela est fait de cette manière uniquement pour aborder et détailler les deux méthodes de configuration. Selon le même principe que le premier routeur la configuration générale ne sera pas reprise et on admettra que tout est configuré correctement. De même l'aspect sécurité ne sera pas abordé.
    2.1 Première étape : configuration générale

    La première opération à effectuerest de configurer un compte pour le routeur distant (ROUTEUR_NUM1). Voici la commande à saisir en mode de configuration global :

    ROUTEUR_NUM2(config)#username ROUTEUR_NUM1 password 0 mot_de_passe

    Ensuite de la même manière que le premier routeur il faut aussi configurer le type de commutateur RNIS et la négociation pour le premier appel reçu ou émit :

    ROUTEUR_NUM2(config)#isdn switch-type vn3

    ROUTEUR_NUM2(config)#isdn tei-negociation first-call

    Jusque là, aucun changement de configuration, sur la commande suivante une légère différence va être rencontrée :

    ROUTEUR_NUM2(config)#ip route 192.168.79.0 255.255.255.0 172.16.26.90 250

    Avec cette commande nous lui spécifions que pour atteindre le réseau 192.168.79.0 il faut qu'il redirige les paquets vers l'adresse IP 172.16.26.90. Ici, en plus une métrique de 250 est utilisée, elle peut poser problème dans certaines configurations et sur certains liens.


    2.2 Deuxième étape : configuration de l'interface BRI0

    Passons maintenant à la configuration de l'interface physique RNIS : BRI0. Voici les différentes commandes à saisir pour que cette interface soit opérationnelle :

    # on rentre dans la configuration de l'interface BRI 0
    ROUTEUR_NUM2(config)#interface bri0
    # on configure l'adresse IP de l'interface
    ROUTEUR_NUM2(config-if)#ip address 172.16.26.3 255.255.255.0
    # on spécifie une encapsulation PPP
    ROUTEUR_NUM2(config-if)#encapsulation ppp
    # on lui spécifie de ne pas rester connecté indéfiniment, très utile surtout dans le cas de liaison
    # RNIS qui peuvent coûter chère à la minute.
    ROUTEUR_NUM2(config-if)#no keepalive
    # spécification du timeout
    ROUTEUR_NUM2(config-if)#dialer idle-timeout 180
    # on lui spécifie que si il reçoit des paquets à destination de l'adresse 172.16.26.90 alors il doit les
    # rediriger vers le routeur ROUTEUR_NUM1 avec le numéro d'appel 0177777777
    ROUTEUR_NUM2(config-if)#dialer map ip 172.16.26.90 name ROUTEUR_NUM1 0177777777
    # spécification de l'authentification
    ROUTEUR_NUM2(config-if)#ppp authentication chap pap
    Avec ce type de configuration, tous les numéros d'appel vers les routeurs distant sont configurés dans l'interface BRI 0.
    Debuggage

    Différentes commandes peuvent être utilisées pour voir les actions qui se déroulent lors de l'établissement des liens RNIS pour vérifier l'intégrité de la configuration effectuée. Voici quelques une de ces commandes :
    #cette commande permet de vérifier les trois premières couche du modèle OSI sur le lien RNIS
    ROUTEUR_NUM2#show isdn status
    The current ISDN Switchtype = vn3
    ISDN BRI0 interface
    Layer 1 Status:
    ACTIVE
    Layer 2 Status:
    TEI = 69, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
    0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask: 0x80000003
    Total Allocated ISDN CCBs = 0
    ROUTEUR_NUM2#
    # cette commande permet de ressortir les événements isdn lors de l'établissement du lien RNIS entre # les deux routeurs distants.
    ROUTEUR_NUM2#debug isdn event
    # les commandes no debug isdn event et undebug all permettent d'arrêter le mode de débuggage
    # parfois lourd à gérer pour le routeur et même dangereux si il gère plusieurs dizaines de
    # connexions.
    # la commande ci-dessous fournit les même information de débuggage que la commande juste au-
    # dessus mais sous un format différent. Pour plus d'information :
    # http://www.cisco.com/warp/public/129/isdn_disc_code.html
    ROUTEUR_NUM2#debug isdn q931
    #les commandes no debug isdn q931 et undebug all permettent d'arrêter le mode de débuggage.
    #La commande show debug permet de voir les modes debug actifs sur le routeur.

    Conclusion

    Ces deux types de configuration sont couramment utilisés. On peut choisir l'une ou l'autre suivant ses besoins, en notant tout de même le point suivant : sur une configuration de type DialerMap, dans le cas de nombreux liens RNIS, cela devient vite illisible alors que sur une configuration de type Dialer Profile chaque routeur distant possède une partie de configuration bien à lui. Le travail de configuration est plus long et répétitif mais plus clair et plus ordonné dans le cas de nombreux lien RNIS.

    Il ne faut pas oublier non plus de couper la ligne dès que possible puisque le principe du RNIS, contrairement à l'ADSL aujourd'hui possède un système de paiement à la minute. De plus, les connexions ne sont pas illimitées dans le temps. C'est pour cette raison que les liens RNIS sont souvent utilisés en cas de problèmes sur les autres liens du réseau : ce sont des liens de secours la plu part du temps.

    Références

    http://www.cisco.com
    http://networking.ringofsaturn.com/Cisco/ciscoisdn.php
    http://www.labo-cisco.com
    CEGELEC – Centre Est – BMS
    Yannick CARTERET
    http://fr.wikipedia.org/wiki/RNIS
    avatar
    aghromino

    Masculin Nombre de messages : 213
    Date d'inscription : 24/07/2006

    Re: RNIS

    Message par aghromino le Mer 7 Fév - 18:41

    avatar
    salime250

    Masculin Nombre de messages : 23
    Age : 35
    Date d'inscription : 05/08/2006

    Re: RNIS

    Message par salime250 le Dim 11 Fév - 11:54


    amona_al

    Féminin Nombre de messages : 7
    Age : 32
    Localisation : errachidia
    Date d'inscription : 24/10/2007

    Re: RNIS

    Message par amona_al le Jeu 25 Oct - 0:06

    merci bcp

    mizou

    Masculin Nombre de messages : 1
    Age : 31
    Localisation : casablanca
    Date d'inscription : 13/05/2008

    Re: RNIS

    Message par mizou le Mer 14 Mai - 20:58

    MERCI....LAH IJAZIK BIHKIR

    Contenu sponsorisé

    Re: RNIS

    Message par Contenu sponsorisé


      La date/heure actuelle est Sam 21 Juil - 12:36